The 'Mayhem for API' API

The Mayhem for API is available in OpenApi 3.0 format and can be interacted with using the online Swagger Editor.

Please note: this is an unstable, pre-release API under active development. If you want to know more, or if you want to build against it, we'd like to hear from you! Please get in touch by emailing us at mayhem4api@forallsecure.com.

Authentication

An API Token is required to access the 'Mayhem for API' API. The token must be presented as a Bearer token in the Authorization header with every request in order to access your resources.

For example, to fetch a list of API Targets directly from the API with curl with your API Token <YOUR_TOKEN>:

curl --request GET 'https://mayhem4api.forallsecure.com/api/v1/api-target' \
--header 'Content-Type: application/json' \
--header 'Authorization: Bearer <YOUR_TOKEN>'